Changing Min Length of Triple Run makes it a SINGLE run

More
2 months 3 weeks ago - 2 months 3 weeks ago #2043 by Pascale R.
running e4.2H 2 Apr 2019 (94-20045) [a0af511e]

This is a dual purpose entry:
1. Report possible bug:
Changing the minimum length of a triple run seems to change the characteristic of object to a SINGLE run:
Please refer to the attached "test ii .....". emb file. *Both attached emb files are from opening DST files (ie. there are no emb original files to open).
Object 54: Applied Triple run with 3.75mm length and default min length of 0.8mm. Using the travel by stitch shows a triple run.

Object 55: Applied Triple run with 3.75mm length and a 2.8mm min length. End up with a SINGLE pass object. This is demonstrated by both the stitch count & travel by stitch, but note that the Color Object list depicts a Triple Run!


I've also attached another file showing the same issue ('test iii .... emb"), objects 27 & 28.

2. What is the best way to accomplish this (besides redigitizing from scratch)?

I am attempting to edit a pre-existing sewing format DST file to make the letters taller. The stitch format of the dst file is a triple run. I am taking the text and making it taller (not editing the width of the letters).

a. If I simply convert to vector and assign it a triple run, I end up getting a double-triple run because there are multiple nodes involved in the original triple run.
As a work around:

a. I apply Edit > close curve to the vector image. Then, I apply the triple run stitch to the object. This works sometimes, but often, l get interspersed double-triple run, as seen when traveling through the design using 1 stitch at a time (which takes a long time, especially when you have multiple letters!)

b. Using the Shaping toolbar, I apply the COMBINE tool to the vector image. Again, I've found that the results aren't always consistent. This work-around was actually suggested by US Wilcom team member, Maria Prcela in Oct 2017 (case support 8774). At that time, she said this was assigned a CAD issue.

That was so long ago, so I'm wondering if there is a better way to accomplish this task now? Thanks!
Attachments:
Last edit: 2 months 3 weeks ago by Pascale R.. Reason: Typo: changing MINIMUM Length (not Cord Gap) causes problem

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #2091 by Petar
Hi Pascale,

With the first item, the settings are not being applied as you expect because the object only contains the cusp point (square nodes). This effectively forces a needle penetration at the node point.

If you change them to curve points (circles) then the expected settings will be applied.

You can do it easily by selecting the object and then selecting all the nodes at once, then press spacebar to change them from square to circle.

With the second item, the best way would be to use combine on the converted vector, then select Triple Run and then in reshaping mode make sure you have curved points.

The issue is still valid and I will also be raising another issue as well.
The following user(s) said Thank You: Pascale R.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #2093 by yogisaw
Hi Pascale R.

you can convert object 55 to run stitch and then reconvert it to triple run it works. but this cannot be solution.

I have seen some cases (in wilcom 2006 also) where the objects are small and after applying triple run, when you travel by single stitch you will notice that some stitches are single run in the same object.

This is the same bug. stitch no. 39656 and 39664 has triple run structure while rest all stitches in the same object is single run.
The following user(s) said Thank You: Pascale R.

Please Log in or Create an account to join the conversation.

Time to create page: 0.217 seconds